하나의 사이트에 특정 폴더는 PHP 하위 버전 5.4, 그리고 또 다른 폴더는 최신 PHP 7.4 버전을 사용할 수 있는 설정 방법입니다.

예전에 운영중인 ExpressEngine 과 WordPress 를 같이 돌려 보려고 한번 설정해봤습니다.

mod_fcgid 모듈 설치 방법은 https://ivps.tistory.com/698 여기를 참고하세요~

 

<VirtualHost *:80>
    ServerName www.example.com
    DocumentRoot /home/example/www
    <IfModule mod_fcgid.c>
        <Directory "/home/example/www">
            Options +ExecCGI
            Require all granted
            AddType application/x-httpd-php .php .html
            AddHandler fcgid-script .php
        </Directory>
        <Directory "/home/example/www/xe">
            FCGIWrapper /var/www/cgi-bin/php54.fcgi .php
        </Directory>
        <Directory "/home/example/www/wp">
            FCGIWrapper /var/www/cgi-bin/php74.fcgi .php
        </Directory>
    </IfModule>
</VirtualHost>

많은 테스트는 안해봤지만 현재까지 잘 동작하네요~

 

블로그 이미지

iVPS 영은파더♥

가상서버호스팅 VPS 리눅스 서버관리 윈도우 IT

댓글을 달아 주세요