CentOS VM 복제후 네트워크가 안되는 경우




virt-clone 으로 VM 을 복제한 후에 아래 처럼 네트워크가 안잡히는 경우에 해결 방법입니다.


# ifup eth0
Device eth0 does not seem to be present, delaying initialization.


먼저 /etc/udev/rules.d/70-persistent-net.rules 파일을 수정합니다.


▶ 수정전


# PCI device 0x1af4:0x1000 (virtio-pci)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="51:54:00:0f:e4:65", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x1af4:0x1000 (virtio-pci)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="51:54:00:5b:70:a2", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"



▶ 수정후


# PCI device 0x1af4:0x1000 (virtio-pci)
#SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="51:54:00:0f:e4:65", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x1af4:0x1000 (virtio-pci)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="51:54:00:5b:70:a2", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"


eth0 부분을 막고 eth1 로 되어 있는 부분은 eth0 로 변경하면 됩니다.


이제 /etc/sysconfig/network-scripts/ifcfg-eth0 파일을 수정합니다.


HWADDR="51:54:00:5b:70:a2"


HWADDR 부분을 찾아서 저위에 있는 MAC Address 로 변경합니다.


재부팅해서 정상적으로 동작하는지 확인합니다.


블로그 이미지

iVPS 영은파더♥

가상서버호스팅 VPS 리눅스 서버관리 윈도우 IT

댓글을 달아 주세요

KVM VM 복제 명령어 virt-clone 사용방법



virt-install 로 설치된 vm 을 복제할 수가 있습니다.


먼저 VM이 작동중이라면 멈춘 다음에 복사가 가능합니다.


▶ VM 일시정지


# virsh suspend c7-a

Domain c7-a suspended

재시작 : virsh resume c7-a ( 복사가 끝나면 재시작 해줍니다. )



▶ VM 복제


# virt-clone --original c7-a \

--name c6-a \

--file /var/lib/libvirt/images/c6-a.img

Allocating 'c6-a.img'                                    |  10 GB     01:11

Clone 'c6-a' created successfully.



▶ VM 시작


# virsh start c6-a
Domain c6-a started



virsh 명령어는 https://ivps.tistory.com/403 여기를 참고하세요~


VM 복제후 네트워크 안되는 문제는 https://ivps.tistory.com/405 여기를 참고하세요~


블로그 이미지

iVPS 영은파더♥

가상서버호스팅 VPS 리눅스 서버관리 윈도우 IT

댓글을 달아 주세요