XMR-STAK g++ version must be at least 5.1!


xmr-stak 이 2.3.0 으로 업데이트 되었다기에 소스를 받아서 컴파일 하려니 아래 처럼 에러가 뜨는군요~

[root@cnh xmr-stak]# cmake3 .

-- The C compiler identification is GNU 4.8.5

-- The CXX compiler identification is GNU 4.8.5

-- Check for working C compiler: /usr/bin/cc

-- Check for working C compiler: /usr/bin/cc -- works

-- Detecting C compiler ABI info

-- Detecting C compiler ABI info - done

-- Detecting C compile features

-- Detecting C compile features - done

-- Check for working CXX compiler: /usr/bin/c++

-- Check for working CXX compiler: /usr/bin/c++ -- works

-- Detecting CXX compiler ABI info

-- Detecting CXX compiler ABI info - done

-- Detecting CXX compile features

-- Detecting CXX compile features - done

CMake Error at CMakeLists.txt:29 (message):

  g++ version must be at least 5.1!



-- Configuring incomplete, errors occurred!

See also "/root/xmr-stak/CMakeFiles/CMakeOutput.log".


[root@cnh xmr-stak]# g++ --version

g++ (GCC) 4.8.5 20150623 (Red Hat 4.8.5-16)

Copyright (C) 2015 Free Software Foundation, Inc.

This is free software; see the source for copying conditions.  There is NO

warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

g++ 버전을 올려야 하나 봅니다.


# yum remove devtoolset-4-gcc*

# yum install devtoolset-7-gcc*

이제 다시 소스를 지우고 새로 받아서 컴파일 하면 됩니다.


블로그 이미지

iVPS 영은파더♥

가상서버호스팅 VPS 리눅스 서버관리 윈도우 IT

Tag

댓글을 달아 주세요